docking speaker

for iPod/iPhone, Clock display DS1150/79

Frequently Asked Questions

What is the system requirement for the iOS App?

The App is supported in iPad, iPhone, iPod running iOS version not later than iOS 10.

The information on this page applies to the following models: DS1150/79 , DS1600/98 , DTB297/10 , DS3480/98 , DS3205/79 , DS8400/10 , DS8300/10 , DS1155/98 , DCB852/79 , AD7050W/10 , DS8550/79 , DS3510/98 , AD7000W/12 , DS8530/79 , DS7600/98 , DS7510/98 , DS9800W/10 , DS1110/79 , DS7700/98 , DS1200/98 , DS3500/98 , DS9/10 , DS1100/98 , DS9000/12 , DS8550/10 , SBD7500/97 , DS9000/10 . more less

Not what you are looking for?

Did we answer your question?

If not, contact us.